【通达信源码】回调买主图和选股指标公式源码 可设为预警

图片

MA5:MA(C,5),COLORFFFFFF;

MA10:MA(C,10),COLOR00FFFF;

MA20:MA(C,20),COLORLIBLUE;

MA60:MA(C,60),COLORLIGREEN;

MA120:=MA(C,120),COLOR0000FF;

DRAWKLINE(H,O,L,C);

BDGD:=C=HHV(C,13);

GDSJ:=BARSLAST(FILTER(CROSS(0.8,BDGD),2))+1;

高点:REF(C,GDSJ),COLORFF00FF,POINTDOT;

突破:CROSS(C,REF(高点,1)),COLOR00FFFF,POINTDOT,NODRAW;

STICKLINE(GDSJ<=6,高点,高点,3,0),COLORFF00FF;

DRAWTEXT(突破,LOW,'↑'),COLOR00FFFF;

BDDD:=C=LLV(C,13);

DDSJ:=BARSLAST(FILTER(CROSS(0.8,BDDD),2))+1;

矮点:REF(C,DDSJ),COLOR00FF00,POINTDOT;

STICKLINE(DDSJ<=6,矮点,矮点,3,0),COLOR00FF00;

LC:=REF(C,1);

RSI5:=((SMA(MAX((C-LC),0),5,1)/SMA(ABS((C-LC)),5,1))*100);

TR1:=SUM(MAX(MAX((H-L),ABS((H-REF(C,1)))),ABS((L-REF(C,1)))),10);

HD:=(H-REF(H,1));

LD:=(REF(L,1)-L);

DMP:=SUM(IF(((HD>0) AND (HD>LD)),欧宝品牌HD,0),10);

DMM:=SUM(IF(((LD>0) AND (LD>HD)),LD,0),10);

PDI:=DMP*100/TR1;

MDI:=DMM*100/TR1;

ADX:=MA(((ABS((MDI-PDI))/(MDI+PDI))*100),5);

AV:=(RSI5+ADX);

DXR:=(((ADX+REF(ADX,5))/2)+RSI5);

WR10:=((100*(HHV(H,10)-C))/(HHV(H,10)-LLV(L,10)));

NEWVOL:=(RSI5-WR10);

回调买:=(AV+NEWVOL);

DRAWTEXT(CROSS(回调买,0),L*0.999,'  回调买'),COLORYELLOW;

DRAWICON(CROSS(回调买,0),L*0.999,11);

DRAWICON(CROSS(回调买,-5),L*0.98,1);

QA:=EMA(C,3);

QB:=EMA(SLOPE(C,8)*18+C,34);

卖:=CROSS(QB,QA);

DRAWICON(卖,H*1.006,15);

DRAWTEXT(卖,H*1.004,'  离场'),COLORCYAN;

 选股指标 (量比及换手按照本身喜欢更改)

{回调买选股}

LC:=REF(C,1);

RSI5:=((SMA(MAX((C-LC),0),5,1)/SMA(ABS((C-LC)),5,1))*100);

TR1:=SUM(MAX(MAX((H-L),ABS((H-REF(C,1)))),ABS((L-REF(C,1)))),10);

HD:=H-REF(H,1);

LD:=REF(L,1)-L;

DMP:=SUM(IF(((HD>0) AND (HD>LD)),HD,0),10);

DMM:=SUM(IF(((LD>0) AND (LD>HD)),LD,0),10);

PDI:=DMP*100/TR1;

MDI:=DMM*100/TR1;

ADX:=MA(((ABS((MDI-PDI))/(MDI+PDI))*100),5);

AV:=RSI5+ADX;

DXR:=(((ADX+REF(ADX,5))/2)+RSI5);

LB:=DYNAINFO(17);

HS:=DYNAINFO(37)*100;

WR10:=((100*(HHV(H,10)-C))/(HHV(H,10)-LLV(L,10)));

NEWVOL:=RSI5-WR10;

AA:=AV+NEWVOL;

CS:CROSS(AA,0) AND LB>1.20 AND HS>1.8;

posted @ 21-03-05 05:53 作者:admin  阅读:

Powered by 欧宝竞猜官网app @2018 RSS地图 HTML地图

2013-2021 欧宝 版权所有