通达信七个主要点位主图指标公式

安置后如下图,友谊挑示(指标只是辅助,不作提出) 一切程序均为免费分享。

不会安置点击 安置指南 步骤操作。

图片

Z1:=STRCAT(DYBLOCK,' ');Z2:=STRCAT(Z1,HYBLOCK);Z3:=STRCAT(Z2,' ');Z4:=STRCAT(Z3,GNBLOCK);Z5:=STRCAT(Z4,' ');Z6:=STRCAT(Z5,FGBLOCK);DRAWTEXT_FIX(ISLASTBAR,0.10,0.058,0,STRCAT(Z6,ZHBLOCK)),COLOR0000FF;DRAWTEXT_FIX(1,0,0.055,0,STRCAT('【所在板块】:',STKNAME)),COLOR00FFFF;K1:=BARSLAST(CURRBARSCOUNT=120);GD1:=CONST(IF(ISLASTBAR=1,HHV(H,K1),0));DD1:=CONST(IF(ISLASTBAR=1,LLV(L,K1),0));KJ:=GD1-DD1;GD4:=IF(CURRBARSCOUNT<=120/2,GD1,DRAWNULL);DRAWTEXT(CURRBARSCOUNT=120,DD1+KJ/10,'====【更多指标关注微信公多号:程序化指标】===='),COLOR889999;{--------------------------------}AA:=EMA(C,5) > EMA(C,19);BB:=EMA(C,5) < EMA(C,19);CC:=EMA(C,5) > EMA(C,10);CC1:=EMA(C,5) < EMA(C,10);DD:=CLOSE<OPEN;E:=EMA(EMA(C,10),10),COLORRED,LINETHICK2;红线:IF(REF(E,1)<E,E,DRAWNULL),COLOR0000FF,LINETHICK2;蓝线:IF(REF(E,1)>E,E,DRAWNULL),COLORFF8000,LINETHICK2;{--------------------------------}W:=EMA(C,5);W1:=EMA(W,8);W2:=REF(W1,1);M:=SMA(CLOSE,8,1);M1:=(SMA(M,11,1));M2:=(REF(M1,1));STICKLINE((W1>W2)AND(W1<M2),W1,W2,1,0),COLOR0000FF;STICKLINE((W1<W2)AND(W1>M2),W1,W2,1,0),COLORC0C0C0;STICKLINE((M1>M2),M1,M2,1,0),COLORFF00FF;STICKLINE((M1<M2),M1,M2,1,0),COLORFF0000;{程序化指标官方网址 WWW.HONGHAIE.COM}高12:=REF(HHV(H,150),3); 矮12:=REF(LLV(L,150),3);H12:=高12-(高12-矮12)*0.191; H22:=高12-(高12-矮12)*0.382; H32:=高12-(高12-矮12)*0.5; H42:=高12-(高12-矮12)*0.618; H52:=高12-(高12-矮12)*0.809;顶:=REFDATE(高12,DATE),COLORFFFF00;一:=REFDATE(H12,DATE),DOTLINE,COLORYELLOW;二:=REFDATE(H22,DATE),DOTLINE,COLORMAGENTA;三:=REFDATE(H32,DATE),COLOR00FFFF;四:=REFDATE(H42,DATE),DOTLINE,COLORMAGENTA;五:=REFDATE(H52,DATE),DOTLINE,COLORYELLOW;矮:=REFDATE(矮12,DATE),COLOR00FF00;TT3:=(CURRBARSCOUNT=8);TT4:=(CURRBARSCOUNT=6);DRAWNUMBER(ISLASTBAR AND 顶,顶,顶),COLOR999900;DRAWTEXT(TT4 AND 顶,顶,'高点'),COLOR80FF00;DRAWNUMBER(ISLASTBAR AND 一,一,一),COLOR999999;DRAWTEXT(TT4 AND 一,一,'压力'),COLORFFCC18;DRAWNUMBER(ISLASTBAR AND 二,二,二),COLOR999999;DRAWTEXT(TT4 AND 二,二,'现在的'),COLORFF18FF;DRAWNUMBER(ISLASTBAR AND 三,三,三),COLOR999999;DRAWTEXT(TT4 AND 三,三,'关键'),COLORFFFFFF;DRAWNUMBER(ISLASTBAR AND 四,四,四),COLOR999999;DRAWTEXT(TT4 AND 四,四,'参考'),COLOR18FF18;DRAWNUMBER(ISLASTBAR AND 五,五,五),COLOR999999;DRAWTEXT(TT4 AND 五,五,'撑持'),COLOR18CCFF;DRAWNUMBER(ISLASTBAR AND 矮,矮*1.01,矮),COLOR999900;DRAWTEXT(TT4 AND 矮,矮*1.009,'矮点'),COLORRED;{--------------------------------}今日卖点:EMA(C,2),NODRAW,COLOR40FF00;今日买点:EMA(SLOPE(C,21)*20+C,42),NODRAW,COLOR0000FF;JC:=(REF(C,3)+REF(C,5)+REF(C,7)+REF(C,8)+REF(C,13)+REF(C,21))/6;参考价:=SMA(JC,5,1),COLORCYAN;价:=IF(C>=参考价,参考价,欧宝品牌参考价*0.98 ), CIRCLEDOT,COLOR0000FF;日:=150;昨前:=3;高1:=REF(HHV(H,日),昨前);矮1:=REF(LLV(L,日),昨前);H1:=高1-(高1-矮1)*0.191; H2:=高1-(高1-矮1)*0.382; H3:=高1-(高1-矮1)*0.5; H4:=高1-(高1-矮1)*0.618; H5:=高1-(高1-矮1)*0.809;{--------------------------------}LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);高点:REFDATE(高1,DATE),COLORGREEN,LINETHICK3;压力:REFDATE(H1,DATE),COLORFFCC18,LINETHICK2;现在的:REFDATE(H2,DATE),COLORMAGENTA,LINETHICK2;关键:REFDATE(H3,DATE),COLORWHITE,LINETHICK2;参考:REFDATE(H4,DATE),COLORGREEN,LINETHICK2;撑持:REFDATE(H5,DATE),COLORYELLOW,LINETHICK2;矮点:REFDATE(矮1,DATE),COLORRED,LINETHICK2;{--------------------------------}X_1:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1003,C,0,L),0);X_2:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1002,TDXDLL1(1003,C,0,L),H,L),0);X_3:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1034,H,C,L),0); X_4:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1035,H,C,L),0); X_5:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1044,H,C,L),0); X_6:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1046,H,C,L),0); X_7:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1002,C,H,L)<TDXDLL1(1002,TDXDLL1(1034,H,C,L),H,L) AND O<TDXDLL1(1034,H,C,L) AND TDXDLL1(1034,H,C,L)>TDXDLL1(1046,H,C,L),0);X_8:=IF(TDXDLL1(8888,C,L,C),TDXDLL1(1002,TDXDLL1(1002,C,H,L)<TDXDLL1(1002,TDXDLL1(1034,H,C,L),H,L) AND O<TDXDLL1(1034,H,C,L) AND TDXDLL1(1034,H,C,L)>TDXDLL1(1046,H,C,L),H,L)=0 AND TDXDLL1(1002,C,H,L)<TDXDLL1(1002,TDXDLL1(1034,H,C,L),H,L) AND O<TDXDLL1(1034,H,C,L) AND TDXDLL1(1034,H,C,L)>TDXDLL1(1046,H,C,L),0); X_9:=EMA(HHV(HIGH,1),8);X_10:=EMA(CLOSE,8);X_11:=X_10<REF(X_10,1) AND CLOSE<X_10;X_12:=IF(X_9<REF(X_9,1) OR X_11,1,0);

版权声明

指标老师有话说:用完记得多多分享文章哦!感谢您的声援!

必要把上面公式改写成选股公式大声呼唤吾!

posted @ 21-03-05 04:40 作者:admin  阅读:

Powered by 欧宝竞猜官网app @2018 RSS地图 HTML地图

2013-2021 欧宝 版权所有